Encryption while you work

Does MediaSeal Decryptor work with macOS 10.14 Mojave?

Modified on: 2019-10-15 15:50:05 +0100



Question


Does MediaSeal Decryptor work with macOS 10.14 Mojave ?


Answer


MediaSeal Decryptor version 3.7.3.79 and above now supports macOS 10.14 Mojave

*Please ensure that you upgrade MediaSeal Decryptor to version 3.7.3.79 or above before upgrading to macOS 10.14 Mojave


Please visit here for a list of support operating systems.



*Please note - macOS 10.13 High Sierra requires MediaSeal version 3.7.1 or above
*Please note - macOS 10.14 Mojave requires MediaSeal version 3.7.3.79 or above
*Please note - macOS 10.15 Catalina requires MediaSeal version 3.9.1.134 or above




Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.
Can you please tell us how we can improve this article?